necam koltec GSI diag method

Hi, I have an chevrolet nubira 2006 equiped with a necam koltec GSI system. Sometimes when I start engine the LED is blinking fastly and therefore the system don't switch on LPG. I must turn on/off severals times to make it work. Other times everything is good. Can you confirm me that "fast blinking" = problem ? It seems to happen only when external temperature is hot >25⁰C but I'm not sure of this. I read somewhere that I could use the grey wire behind the switch to make autodiagnostic with the led but, as the wire is already wired I'm not sure my system is compatible ? Here's some pictures of my installation : http://picasaweb.google.com/personseb/GPL?feat=directlink I saw you helped many peoples so if you have time to help me a bit I will enjoy it! Thanks for reading. Seb.

2 Answers

despdesp1 Jul 2010
Ground that wire when driving and you will see if the oxygene sensor works fine. Ground it with ignition on and engine off and the light will blink error codes you can check with error codes table kver gave you.
Reply
KverKver26 May 2010
Hi Sebastian, The grey wire for diagnostic is behind the switch at the old Koltec-Necam EGI systems. At your system is the grey wire in the 4-pole connector in the neighbourhood of the LPG ecu. That connector is to see on your last picture. A manual for read out is attached. Succes, Kees
Reply
authorka2er 28 May 2010
Thanks for the input. So I put a wire beetwen the grey wire (2nd position on the connector and on the left on the photo) and the ground of the car , turned on the contact but not the engine. The 2 opposite led on the switch get on and after 2 second go off. Does it mean that there is no error code ?
Didn't find an answer?Ask your question